Flash в Linux

Linux - свободная ОС. В большинство ее дистрибутивов не входит поставка каких-либо проприетарных, закрытых и платных компонентов, таких как драйвера или кодеки.
Чтобы иметь возможность смотреть видео на сайтах, значительная часть из которых (пока все еще) требует установки flash, нам придется установить его отдельно.

Если ваш подход к выбору программного обеспечения допускает использование несвободных компонентов, устанавливаем закрытый flash от Adobe.

Сделать это можно несколькими способами:

1) Установить метапакет ubuntu-restricted-extras. В его состав входят различные кодеки, флеш, java, шрифты windows - многое из того что бывает необходимо Windows-пользователям.

apt-get install ubuntu-restricted-extras

2) Установить flashplugin-nonfree или adobe-flashplugin. Это один и тот же пакет. Разница состоит лишь в различии версий. В adobe-flashplugin - включена более новая весия плагина от Adobe чем в flashplugin-nonfree

apt-get install adobe-flashplugin

apt-get install flashplugin-nonfree

Так же можно воспользоваться промежуточным вариантом и установить в систему свободную реализацию flash от GNU.

Gnash:

apt-get install gnash mozilla-plugin-gnash


Lightspark
:

Добавить репозиторий и обновить:

add-apt-repository ppa:sparkers/ppa
apt-get update

apt-get install lightspark browser-plugin-lightspark

Основной недостаток такого подхода состоит в том что свободный flash воспроизводит видео не на всех сайтах. Но для Youtube вполне подходит.

Ключевые слова: